summaryrefslogtreecommitdiffstats
path: root/external/libatomic_ops
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /external/libatomic_ops
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'external/libatomic_ops')
-rw-r--r--external/libatomic_ops/ExternalProject_libatomic_ops.mk33
-rw-r--r--external/libatomic_ops/Makefile7
-rw-r--r--external/libatomic_ops/Module_libatomic_ops.mk17
-rw-r--r--external/libatomic_ops/README4
-rw-r--r--external/libatomic_ops/UnpackedTarball_libatomic_ops.mk16
5 files changed, 77 insertions, 0 deletions
diff --git a/external/libatomic_ops/ExternalProject_libatomic_ops.mk b/external/libatomic_ops/ExternalProject_libatomic_ops.mk
new file mode 100644
index 000000000..143eed2c0
--- /dev/null
+++ b/external/libatomic_ops/ExternalProject_libatomic_ops.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalProject_ExternalProject,libatomic_ops))
+
+$(eval $(call gb_ExternalProject_use_autoconf,libatomic_ops,build))
+
+$(eval $(call gb_ExternalProject_register_targets,libatomic_ops,\
+ build \
+))
+
+$(call gb_ExternalProject_get_state_target,libatomic_ops,build) :
+ $(call gb_Trace_StartRange,libatomic_ops,EXTERNAL)
+ $(call gb_ExternalProject_run,build,\
+ $(if $(filter TRUE, \
+ $(DISABLE_DYNLOADING)) \
+ , \
+ CFLAGS="$(CFLAGS) $(gb_VISIBILITY_FLAGS) $(call gb_ExternalProject_get_build_flags,libatomic_ops)" \
+ CXXFLAGS="$(CXXFLAGS) $(gb_VISIBILITY_FLAGS) $(gb_VISIBILITY_FLAGS_CXX) $(call gb_ExternalProject_get_build_flags,libatomic_ops)" \
+ LDFLAGS="$(call gb_ExternalProject_get_link_flags,libatomic_ops)") \
+ $(gb_RUN_CONFIGURE) ./configure \
+ $(gb_CONFIGURE_PLATFORMS) \
+ && $(MAKE) \
+ )
+ $(call gb_Trace_EndRange,libatomic_ops,EXTERNAL)
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libatomic_ops/Makefile b/external/libatomic_ops/Makefile
new file mode 100644
index 000000000..e4968cf85
--- /dev/null
+++ b/external/libatomic_ops/Makefile
@@ -0,0 +1,7 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+
+module_directory:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+include $(module_directory)/../../solenv/gbuild/partial_build.mk
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libatomic_ops/Module_libatomic_ops.mk b/external/libatomic_ops/Module_libatomic_ops.mk
new file mode 100644
index 000000000..7dca6703c
--- /dev/null
+++ b/external/libatomic_ops/Module_libatomic_ops.mk
@@ -0,0 +1,17 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,libatomic_ops))
+
+$(eval $(call gb_Module_add_targets,libatomic_ops,\
+ ExternalProject_libatomic_ops \
+ UnpackedTarball_libatomic_ops \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libatomic_ops/README b/external/libatomic_ops/README
new file mode 100644
index 000000000..3dcb7ef7a
--- /dev/null
+++ b/external/libatomic_ops/README
@@ -0,0 +1,4 @@
+From [https://github.com/ivmai/libatomic_ops/].
+
+Note that some files (linked into libatomic_ops_gpl) are GPL'd, the portion
+needed for Firebird (libatomic_ops) is however MIT licensed.
diff --git a/external/libatomic_ops/UnpackedTarball_libatomic_ops.mk b/external/libatomic_ops/UnpackedTarball_libatomic_ops.mk
new file mode 100644
index 000000000..652b8381a
--- /dev/null
+++ b/external/libatomic_ops/UnpackedTarball_libatomic_ops.mk
@@ -0,0 +1,16 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,libatomic_ops))
+
+$(eval $(call gb_UnpackedTarball_set_tarball,libatomic_ops,$(LIBATOMIC_OPS_TARBALL)))
+
+$(eval $(call gb_UnpackedTarball_update_autoconf_configs,libatomic_ops))
+
+# vim: set noet sw=4 ts=4: