summaryrefslogtreecommitdiffstats
path: root/i18npool/CustomTarget_textconversion.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /i18npool/CustomTarget_textconversion.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'i18npool/CustomTarget_textconversion.mk')
-rw-r--r--i18npool/CustomTarget_textconversion.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/i18npool/CustomTarget_textconversion.mk b/i18npool/CustomTarget_textconversion.mk
new file mode 100644
index 000000000..d91906c4d
--- /dev/null
+++ b/i18npool/CustomTarget_textconversion.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,i18npool/textconversion))
+
+$(call gb_CustomTarget_get_target,i18npool/textconversion) : \
+ $(patsubst %.dic,$(call gb_CustomTarget_get_workdir,i18npool/textconversion)/%.cxx,$(notdir \
+ $(wildcard $(SRCDIR)/i18npool/source/textconversion/data/*.dic)))
+
+$(call gb_CustomTarget_get_workdir,i18npool/textconversion)/%.cxx : \
+ $(SRCDIR)/i18npool/source/textconversion/data/%.dic \
+ $(call gb_Executable_get_runtime_dependencies,genconv_dict) \
+ | $(call gb_CustomTarget_get_workdir,i18npool/textconversion)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),CDC,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),CDC)
+ $(call gb_Helper_abbreviate_dirs, \
+ $(call gb_Helper_execute,genconv_dict) $* $< $@.tmp && \
+ sed 's/\(^.*get\)/SAL_DLLPUBLIC_EXPORT \1/' $@.tmp > $@ && \
+ rm $@.tmp)
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),CDC)
+
+# vim: set noet sw=4 ts=4: