summaryrefslogtreecommitdiffstats
path: root/i18npool/Module_i18npool.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /i18npool/Module_i18npool.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'i18npool/Module_i18npool.mk')
-rw-r--r--i18npool/Module_i18npool.mk51
1 files changed, 51 insertions, 0 deletions
diff --git a/i18npool/Module_i18npool.mk b/i18npool/Module_i18npool.mk
new file mode 100644
index 000000000..1797db8c3
--- /dev/null
+++ b/i18npool/Module_i18npool.mk
@@ -0,0 +1,51 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,i18npool))
+
+$(eval $(call gb_Module_add_targets,i18npool,\
+ CustomTarget_breakiterator \
+ CustomTarget_collator \
+ CustomTarget_indexentry \
+ CustomTarget_localedata \
+ CustomTarget_textconversion \
+ Library_collator_data \
+ $(if $(filter-out iOS ANDROID,$(OS)), \
+ Library_dict_ja \
+ Library_dict_zh) \
+ Library_i18npool \
+ Library_i18nsearch \
+ Library_index_data \
+ Library_localedata_en \
+ Library_localedata_es \
+ Library_localedata_euro \
+ Library_localedata_others \
+ Library_textconv_dict \
+))
+
+$(eval $(call gb_Module_add_targets_for_build,i18npool,\
+ Executable_gencoll_rule \
+ Executable_genconv_dict \
+ Executable_gendict \
+ Executable_genindex_data \
+ Executable_saxparser \
+ Rdb_saxparser \
+))
+
+$(eval $(call gb_Module_add_check_targets,i18npool,\
+ CppunitTest_i18npool_breakiterator \
+ CppunitTest_i18npool_characterclassification \
+ CppunitTest_i18npool_ordinalsuffix \
+ CppunitTest_i18npool_textsearch \
+ CppunitTest_i18npool_calendar \
+ CppunitTest_i18npool_defaultnumberingprovider \
+ CppunitTest_i18npool_transliteration \
+))
+
+# vim: set noet sw=4 ts=4: