summaryrefslogtreecommitdiffstats
path: root/javaunohelper/JunitTest_juh.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /javaunohelper/JunitTest_juh.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'javaunohelper/JunitTest_juh.mk')
-rw-r--r--javaunohelper/JunitTest_juh.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/javaunohelper/JunitTest_juh.mk b/javaunohelper/JunitTest_juh.mk
new file mode 100644
index 000000000..e5ccfa1c4
--- /dev/null
+++ b/javaunohelper/JunitTest_juh.mk
@@ -0,0 +1,44 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_JunitTest_JunitTest,juh))
+
+$(eval $(call gb_JunitTest_set_defs,juh,\
+ $$(DEFS) \
+ -XX:MaxGCPauseMillis=50 \
+))
+
+$(eval $(call gb_JunitTest_use_jars,juh,\
+ OOoRunner \
+ libreoffice \
+))
+
+$(eval $(call gb_JunitTest_use_jar_classset,juh,libreoffice))
+
+$(eval $(call gb_JunitTest_add_sourcefiles,juh,\
+ javaunohelper/test/com/sun/star/comp/helper/ComponentContext_Test \
+ javaunohelper/test/com/sun/star/lib/uno/helper/AWeakBase \
+ javaunohelper/test/com/sun/star/lib/uno/helper/ComponentBase_Test \
+ javaunohelper/test/com/sun/star/lib/uno/helper/InterfaceContainer_Test \
+ javaunohelper/test/com/sun/star/lib/uno/helper/MultiTypeInterfaceContainer_Test \
+ javaunohelper/test/com/sun/star/lib/uno/helper/PropertySet_Test \
+ javaunohelper/test/com/sun/star/lib/uno/helper/ProxyProvider \
+ javaunohelper/test/com/sun/star/lib/uno/helper/WeakBase_Test \
+))
+
+$(eval $(call gb_JunitTest_add_classes,juh,\
+ com.sun.star.comp.helper.ComponentContext_Test \
+ com.sun.star.lib.uno.helper.ComponentBase_Test \
+ com.sun.star.lib.uno.helper.InterfaceContainer_Test \
+ com.sun.star.lib.uno.helper.MultiTypeInterfaceContainer_Test \
+ com.sun.star.lib.uno.helper.PropertySet_Test \
+ com.sun.star.lib.uno.helper.WeakBase_Test \
+))
+
+# vim:set noet sw=4 ts=4: