summaryrefslogtreecommitdiffstats
path: root/odk/Package_config.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /odk/Package_config.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/Package_config.mk')
-rw-r--r--odk/Package_config.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/odk/Package_config.mk b/odk/Package_config.mk
new file mode 100644
index 000000000..f3786216b
--- /dev/null
+++ b/odk/Package_config.mk
@@ -0,0 +1,29 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Package_Package,odk_config,$(SRCDIR)))
+
+$(eval $(call gb_Package_set_outdir,odk_config,$(INSTDIR)))
+
+ifeq ($(OS),WNT)
+$(eval $(call gb_Package_add_files,odk_config,$(SDKDIRNAME),\
+ odk/config/cfgWin.js \
+ odk/config/setsdkname.bat \
+))
+else
+$(eval $(call gb_Package_add_files,odk_config,$(SDKDIRNAME),\
+ config.guess \
+ config.sub \
+ odk/config/configure.pl \
+ odk/config/setsdkenv_unix \
+ odk/config/setsdkenv_unix.sh.in \
+))
+endif
+
+# vim: set noet sw=4 ts=4: