summaryrefslogtreecommitdiffstats
path: root/odk/examples/python/toolpanel/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /odk/examples/python/toolpanel/Makefile
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/examples/python/toolpanel/Makefile')
-rw-r--r--odk/examples/python/toolpanel/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/odk/examples/python/toolpanel/Makefile b/odk/examples/python/toolpanel/Makefile
new file mode 100644
index 000000000..a2e77f057
--- /dev/null
+++ b/odk/examples/python/toolpanel/Makefile
@@ -0,0 +1,29 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+PRJ = ../../..
+SETTINGS = $(PRJ)/settings
+
+include $(SETTINGS)/settings.mk
+include $(SETTINGS)/std.mk
+
+FILES = \
+ CalcWindowState.xcu \
+ Factory.xcu \
+ META-INF/manifest.xml \
+ description.xml \
+ toolPanelPocBasic/Module1.xba \
+ toolPanelPocBasic/dialog.xlb \
+ toolPanelPocBasic/script.xlb \
+ toolpanel.component \
+ toolpanel.py \
+ toolpanels/poc.xdl
+
+$(OUT_BIN)/toolpanel.$(UNOOXT_EXT): $(FILES)
+ -$(MKDIR) $(subst /,$(PS),$(@D))
+ $(SDK_ZIP) $@ $^