summaryrefslogtreecommitdiffstats
path: root/package/CppunitTest_package2_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /package/CppunitTest_package2_test.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'package/CppunitTest_package2_test.mk')
-rw-r--r--package/CppunitTest_package2_test.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/package/CppunitTest_package2_test.mk b/package/CppunitTest_package2_test.mk
new file mode 100644
index 000000000..546da10de
--- /dev/null
+++ b/package/CppunitTest_package2_test.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,package2_test))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,package2_test, \
+ package/qa/cppunit/test_package \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,package2_test, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+ unotest \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,package2_test))
+
+$(eval $(call gb_CppunitTest_use_components,package2_test,\
+ configmgr/source/configmgr \
+ package/util/package2 \
+ ucb/source/core/ucb1 \
+ ucb/source/ucp/file/ucpfile1 \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,package2_test))
+
+$(eval $(call gb_CppunitTest_use_configuration,package2_test))
+
+# vim: set noet sw=4 ts=4: