summaryrefslogtreecommitdiffstats
path: root/pyuno/CustomTarget_python_shell.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /pyuno/CustomTarget_python_shell.mk
parentInitial commit. (diff)
downloadlibreoffice-cb75148ebd0135178ff46f89a30139c44f8d2040.tar.xz
libreoffice-cb75148ebd0135178ff46f89a30139c44f8d2040.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyuno/CustomTarget_python_shell.mk')
-rw-r--r--pyuno/CustomTarget_python_shell.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/pyuno/CustomTarget_python_shell.mk b/pyuno/CustomTarget_python_shell.mk
new file mode 100644
index 000000000..541620304
--- /dev/null
+++ b/pyuno/CustomTarget_python_shell.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,pyuno/python_shell))
+
+$(eval $(call gb_CustomTarget_register_targets,pyuno/python_shell,\
+ os.sh \
+ python.sh \
+))
+
+ifeq ($(OS),MACOSX)
+pyuno_PYTHON_SHELL_VERSION:=$(PYTHON_VERSION_MAJOR).$(PYTHON_VERSION_MINOR)
+else
+pyuno_PYTHON_SHELL_VERSION:=$(PYTHON_VERSION)
+endif
+
+$(call gb_CustomTarget_get_workdir,pyuno/python_shell)/python.sh : \
+ $(SRCDIR)/pyuno/zipcore/python.sh \
+ $(call gb_CustomTarget_get_workdir,pyuno/python_shell)/os.sh
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),CAT,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),CAT)
+ cat $^ > $@ && chmod +x $@
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),CAT)
+
+$(call gb_CustomTarget_get_workdir,pyuno/python_shell)/os.sh : \
+ $(SRCDIR)/pyuno/zipcore/$(if $(filter MACOSX,$(OS)),mac,nonmac).sh \
+ $(BUILDDIR)/config_$(gb_Side)/config_python.h
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),SED,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),SED)
+ sed -e "s/%%PYVERSION%%/$(pyuno_PYTHON_SHELL_VERSION)/g" \
+ $< > $@
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),SED)
+
+# vim: set noet sw=4 ts=4: