summaryrefslogtreecommitdiffstats
path: root/sal/Library_sal_textenc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /sal/Library_sal_textenc.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--sal/Library_sal_textenc.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/sal/Library_sal_textenc.mk b/sal/Library_sal_textenc.mk
new file mode 100644
index 000000000..0fba5d083
--- /dev/null
+++ b/sal/Library_sal_textenc.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,sal_textenc))
+
+$(eval $(call gb_Library_set_plugin_for,sal_textenc,sal))
+
+$(eval $(call gb_Library_use_external,sal_textenc,boost_headers))
+
+$(eval $(call gb_Library_add_exception_objects,sal_textenc,\
+ sal/textenc/context \
+ sal/textenc/convertbig5hkscs \
+ sal/textenc/converteuctw \
+ sal/textenc/convertgb18030 \
+ sal/textenc/convertisciidevangari \
+ sal/textenc/convertiso2022cn \
+ sal/textenc/convertiso2022jp \
+ sal/textenc/convertiso2022kr \
+ sal/textenc/convertsinglebytetobmpunicode \
+ sal/textenc/tables \
+ sal/textenc/tcvtbyte \
+ sal/textenc/tcvtmb \
+ sal/textenc/tcvtutf7 \
+))
+
+# vim: set noet sw=4 ts=4: