summaryrefslogtreecommitdiffstats
path: root/sdext/Executable_pdf2xml.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /sdext/Executable_pdf2xml.mk
parentInitial commit. (diff)
downloadlibreoffice-cb75148ebd0135178ff46f89a30139c44f8d2040.tar.xz
libreoffice-cb75148ebd0135178ff46f89a30139c44f8d2040.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sdext/Executable_pdf2xml.mk')
-rw-r--r--sdext/Executable_pdf2xml.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/sdext/Executable_pdf2xml.mk b/sdext/Executable_pdf2xml.mk
new file mode 100644
index 000000000..81e00eca1
--- /dev/null
+++ b/sdext/Executable_pdf2xml.mk
@@ -0,0 +1,44 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,pdf2xml))
+
+$(eval $(call gb_Executable_use_sdk_api,pdf2xml))
+
+$(eval $(call gb_Executable_use_externals,pdf2xml,\
+ boost_headers \
+ cppunit \
+ zlib \
+))
+
+$(eval $(call gb_Executable_set_include,pdf2xml,\
+ -I$(SRCDIR)/sdext/source/pdfimport/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Executable_use_libraries,pdf2xml,\
+ basegfx \
+ vcl \
+ comphelper \
+ cppu \
+ unotest \
+ cppuhelper \
+ sal \
+ tl \
+ xo \
+ i18nutil \
+))
+
+$(eval $(call gb_Executable_use_library_objects,pdf2xml,pdfimport))
+
+$(eval $(call gb_Executable_add_exception_objects,pdf2xml,\
+ sdext/source/pdfimport/test/pdf2xml \
+))
+
+# vim:set noet sw=4 ts=4: