summaryrefslogtreecommitdiffstats
path: root/setup_native/Module_setup_native.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /setup_native/Module_setup_native.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup_native/Module_setup_native.mk')
-rw-r--r--setup_native/Module_setup_native.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/setup_native/Module_setup_native.mk b/setup_native/Module_setup_native.mk
new file mode 100644
index 000000000..42fa14217
--- /dev/null
+++ b/setup_native/Module_setup_native.mk
@@ -0,0 +1,41 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,setup_native))
+
+$(eval $(call gb_Module_add_targets,setup_native,\
+ $(if $(filter MACOSX,$(OS)),CustomTarget_mac) \
+ CustomTarget_spell \
+ $(if $(filter WNT,$(OS)),Package_misc) \
+ Package_packinfo \
+ $(if $(filter LINUX SOLARIS,$(OS)), \
+ CustomTarget_scripts \
+ $(if $(ENABLE_ONLINE_UPDATE),Package_scripts) \
+ ) \
+))
+
+ifeq ($(OS),WNT)
+$(eval $(call gb_Module_add_targets,setup_native,\
+ Library_instooofiltmsi \
+ Library_inst_msu_msi \
+ Library_qslnkmsi \
+ Library_reg_dlls \
+ Library_reg4allmsdoc \
+ Library_regactivex \
+ Library_sdqsmsi \
+ Library_sellangmsi \
+ Library_shlxtmsi \
+ Library_sn_tools \
+ StaticLibrary_quickstarter \
+ StaticLibrary_seterror \
+))
+
+endif
+
+# vim: set noet sw=4 ts=4: