summaryrefslogtreecommitdiffstats
path: root/shell/Library_losessioninstall.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /shell/Library_losessioninstall.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/Library_losessioninstall.mk')
-rw-r--r--shell/Library_losessioninstall.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/shell/Library_losessioninstall.mk b/shell/Library_losessioninstall.mk
new file mode 100644
index 000000000..1c95a2dd7
--- /dev/null
+++ b/shell/Library_losessioninstall.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,losessioninstall))
+
+$(eval $(call gb_Library_set_componentfile,losessioninstall,shell/source/sessioninstall/losessioninstall,services))
+
+$(eval $(call gb_Library_use_api,losessioninstall,\
+ offapi \
+ udkapi \
+))
+
+$(eval $(call gb_Library_use_libraries,losessioninstall,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+))
+
+$(eval $(call gb_Library_use_externals,losessioninstall,\
+ boost_headers \
+ dbus \
+ gio \
+))
+
+$(eval $(call gb_Library_add_exception_objects,losessioninstall,\
+ shell/source/sessioninstall/SyncDbusSessionHelper \
+))
+
+# vim:set noet sw=4 ts=4: