summaryrefslogtreecommitdiffstats
path: root/starmath/Library_sm.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /starmath/Library_sm.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'starmath/Library_sm.mk')
-rw-r--r--starmath/Library_sm.mk127
1 files changed, 127 insertions, 0 deletions
diff --git a/starmath/Library_sm.mk b/starmath/Library_sm.mk
new file mode 100644
index 000000000..aa824cee5
--- /dev/null
+++ b/starmath/Library_sm.mk
@@ -0,0 +1,127 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,sm))
+
+$(eval $(call gb_Library_add_sdi_headers,sm,starmath/sdi/smslots))
+
+$(eval $(call gb_Library_set_componentfile,sm,starmath/util/sm,services))
+
+$(eval $(call gb_Library_set_precompiled_header,sm,starmath/inc/pch/precompiled_sm))
+
+$(eval $(call gb_Library_set_include,sm,\
+ -I$(SRCDIR)/starmath/inc \
+ -I$(SRCDIR)/starmath/inc/mathml \
+ -I$(WORKDIR)/SdiTarget/starmath/sdi \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_add_defs,sm,\
+ -DSM_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_use_externals,sm, \
+ boost_headers \
+ icu_headers \
+))
+
+$(eval $(call gb_Library_use_custom_headers,sm,\
+ officecfg/registry \
+ oox/generated \
+))
+
+$(eval $(call gb_Library_use_sdk_api,sm))
+
+$(eval $(call gb_Library_use_libraries,sm,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ editeng \
+ i18nutil \
+ i18nlangtag \
+ msfilter \
+ oox \
+ sal \
+ salhelper \
+ sax \
+ sfx \
+ sot \
+ svl \
+ svt \
+ svx \
+ svxcore \
+ tk \
+ tl \
+ utl \
+ vcl \
+ xo \
+))
+
+$(eval $(call gb_Library_add_exception_objects,sm,\
+ starmath/source/ElementsDockingWindow \
+ starmath/source/SmElementsPanel \
+ starmath/source/SmPanelFactory \
+ starmath/source/SmPropertiesPanel \
+ starmath/source/accessibility \
+ starmath/source/action \
+ starmath/source/caret \
+ starmath/source/cfgitem \
+ starmath/source/cursor \
+ starmath/source/dialog \
+ starmath/source/document \
+ starmath/source/edit \
+ starmath/source/smediteng \
+ starmath/source/format \
+ starmath/source/mathtype \
+ starmath/source/node \
+ starmath/source/ooxmlexport \
+ starmath/source/ooxmlimport \
+ starmath/source/rtfexport \
+ starmath/source/parsebase \
+ starmath/source/parse \
+ starmath/source/parse5 \
+ starmath/source/rect \
+ starmath/source/smdll \
+ starmath/source/smmod \
+ starmath/source/symbol \
+ starmath/source/tmpdevice \
+ starmath/source/typemap \
+ starmath/source/unodoc \
+ starmath/source/unofilter \
+ starmath/source/unomodel \
+ starmath/source/utility \
+ starmath/source/view \
+ starmath/source/visitors \
+ starmath/source/wordexportbase \
+ starmath/source/mathml/xparsmlbase \
+ starmath/source/mathml/mathmlattr \
+ starmath/source/mathml/mathmlexport \
+ starmath/source/mathml/mathmlimport \
+ starmath/source/mathml/mathmlMo \
+ starmath/source/mathml/export \
+ starmath/source/mathml/import \
+ starmath/source/mathml/iterator \
+ starmath/source/mathml/attribute \
+ starmath/source/mathml/element \
+ starmath/source/mathml/def \
+ starmath/source/mathml/starmathdatabase \
+))
+
+
+$(eval $(call gb_SdiTarget_SdiTarget,starmath/sdi/smslots,starmath/sdi/smath))
+
+$(eval $(call gb_SdiTarget_set_include,starmath/sdi/smslots,\
+ -I$(SRCDIR)/starmath/inc \
+ -I$(SRCDIR)/starmath/sdi \
+ -I$(SRCDIR)/svx/sdi \
+ -I$(SRCDIR)/sfx2/sdi \
+ $$(INCLUDE) \
+))
+
+# vim: set noet sw=4 ts=4: