summaryrefslogtreecommitdiffstats
path: root/unotest/Jar_test-tools.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /unotest/Jar_test-tools.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unotest/Jar_test-tools.mk')
-rw-r--r--unotest/Jar_test-tools.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/unotest/Jar_test-tools.mk b/unotest/Jar_test-tools.mk
new file mode 100644
index 000000000..2f8034813
--- /dev/null
+++ b/unotest/Jar_test-tools.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Jar_Jar,test-tools))
+
+$(eval $(call gb_Jar_add_manifest_classpath,test-tools,\
+ libreoffice.jar \
+))
+
+$(eval $(call gb_Jar_use_jars,test-tools,\
+ libreoffice \
+))
+
+$(eval $(call gb_Jar_set_packageroot,test-tools,org))
+
+$(eval $(call gb_Jar_add_sourcefiles,test-tools,\
+ unotest/source/java/org/openoffice/test/tools/DocumentType \
+ unotest/source/java/org/openoffice/test/tools/OfficeDocument \
+ unotest/source/java/org/openoffice/test/tools/OfficeDocumentView \
+ unotest/source/java/org/openoffice/test/tools/SpreadsheetDocument \
+ unotest/source/java/org/openoffice/test/tools/SpreadsheetView \
+))
+
+# vim: set noet sw=4 ts=4: