summaryrefslogtreecommitdiffstats
path: root/unotest/Library_unotest.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /unotest/Library_unotest.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unotest/Library_unotest.mk')
-rw-r--r--unotest/Library_unotest.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/unotest/Library_unotest.mk b/unotest/Library_unotest.mk
new file mode 100644
index 000000000..1a7f8ba5a
--- /dev/null
+++ b/unotest/Library_unotest.mk
@@ -0,0 +1,45 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,unotest))
+
+$(eval $(call gb_Library_add_defs,unotest,\
+ -DOOO_DLLIMPLEMENTATION_UNOTEST \
+))
+
+$(eval $(call gb_Library_use_sdk_api,unotest))
+
+$(eval $(call gb_Library_use_libraries,unotest,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ sb \
+ tl \
+ utl \
+))
+
+$(eval $(call gb_Library_use_externals,unotest,\
+ boost_headers \
+ cppunit \
+))
+
+$(eval $(call gb_Library_add_exception_objects,unotest,\
+ unotest/source/cpp/bootstrapfixturebase \
+ unotest/source/cpp/directories \
+ unotest/source/cpp/filters-test \
+ unotest/source/cpp/getargument \
+ unotest/source/cpp/gettestargument \
+ unotest/source/cpp/macros_test \
+ unotest/source/cpp/officeconnection \
+ unotest/source/cpp/toabsolutefileurl \
+))
+
+# vim: set noet sw=4 ts=4: