summaryrefslogtreecommitdiffstats
path: root/xmloff/CustomTarget_generated.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /xmloff/CustomTarget_generated.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'xmloff/CustomTarget_generated.mk')
-rw-r--r--xmloff/CustomTarget_generated.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/xmloff/CustomTarget_generated.mk b/xmloff/CustomTarget_generated.mk
new file mode 100644
index 000000000..fe135c2b3
--- /dev/null
+++ b/xmloff/CustomTarget_generated.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,xmloff/generated))
+
+#Generates a hashtable for the odf-tags
+xmloff_SRC := $(SRCDIR)/xmloff/source/token
+xmloff_MISC := $(call gb_CustomTarget_get_workdir,xmloff/generated)/misc
+xmloff_INC := $(call gb_CustomTarget_get_workdir,xmloff/generated)
+xmloff_GENHEADERPATH := $(xmloff_INC)/xmloff/token
+
+$(eval $(call gb_CustomTarget_token_hash,xmloff/generated,tokenhash.inc,tokenhash.gperf))
+$(eval $(call gb_CustomTarget_generate_tokens,xmloff/generated,xmloff,xmloff/source/token,tokens,token,tokenhash.gperf))
+
+$(call gb_CustomTarget_get_target,xmloff/generated) : \
+ $(xmloff_INC)/tokenhash.inc \
+ $(xmloff_INC)/tokennames.inc \
+ $(xmloff_GENHEADERPATH)/tokens.hxx \
+
+# vim: set noet sw=4 ts=4: