summaryrefslogtreecommitdiffstats
path: root/bean/JunitTest_bean_complex.mk
diff options
context:
space:
mode:
Diffstat (limited to 'bean/JunitTest_bean_complex.mk')
-rw-r--r--bean/JunitTest_bean_complex.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/bean/JunitTest_bean_complex.mk b/bean/JunitTest_bean_complex.mk
new file mode 100644
index 000000000..42baf49cd
--- /dev/null
+++ b/bean/JunitTest_bean_complex.mk
@@ -0,0 +1,28 @@
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_JunitTest_JunitTest,bean_complex))
+
+$(eval $(call gb_JunitTest_use_jars,bean_complex,\
+ OOoRunner \
+ libreoffice \
+ test \
+ officebean \
+))
+
+$(eval $(call gb_JunitTest_add_sourcefiles,bean_complex,\
+ bean/qa/complex/bean/OOoBeanTest \
+ bean/qa/complex/bean/ScreenComparer \
+ bean/qa/complex/bean/WriterFrame \
+))
+
+$(eval $(call gb_JunitTest_add_classes,bean_complex,\
+ complex.bean.OOoBeanTest \
+))