summaryrefslogtreecommitdiffstats
path: root/canvas/Library_vclcanvas.mk
diff options
context:
space:
mode:
Diffstat (limited to 'canvas/Library_vclcanvas.mk')
-rw-r--r--canvas/Library_vclcanvas.mk70
1 files changed, 70 insertions, 0 deletions
diff --git a/canvas/Library_vclcanvas.mk b/canvas/Library_vclcanvas.mk
new file mode 100644
index 000000000..0f10d2a3c
--- /dev/null
+++ b/canvas/Library_vclcanvas.mk
@@ -0,0 +1,70 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,vclcanvas))
+
+$(eval $(call gb_Library_set_include,vclcanvas,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/canvas/inc \
+))
+
+$(eval $(call gb_Library_set_precompiled_header,vclcanvas,canvas/inc/pch/precompiled_vclcanvas))
+
+$(eval $(call gb_Library_set_componentfile,vclcanvas,canvas/source/vcl/vclcanvas,services))
+
+$(eval $(call gb_Library_use_external,vclcanvas,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,vclcanvas))
+
+$(eval $(call gb_Library_use_libraries,vclcanvas,\
+ basegfx \
+ canvastools \
+ comphelper \
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ sal \
+ svt \
+ tk \
+ tl \
+ vcl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,vclcanvas,\
+ canvas/source/vcl/backbuffer \
+ canvas/source/vcl/bitmapbackbuffer \
+ canvas/source/vcl/cachedbitmap \
+ canvas/source/vcl/canvas \
+ canvas/source/vcl/canvasbitmap \
+ canvas/source/vcl/canvasbitmaphelper \
+ canvas/source/vcl/canvascustomsprite \
+ canvas/source/vcl/canvasfont \
+ canvas/source/vcl/canvashelper \
+ canvas/source/vcl/devicehelper \
+ canvas/source/vcl/impltools \
+ canvas/source/vcl/spritecanvas \
+ canvas/source/vcl/spritecanvashelper \
+ canvas/source/vcl/spritedevicehelper \
+ canvas/source/vcl/spritehelper \
+ canvas/source/vcl/textlayout \
+ canvas/source/vcl/canvashelper_texturefill \
+ canvas/source/vcl/windowoutdevholder \
+))
+
+# vim: set noet sw=4 ts=4: