summaryrefslogtreecommitdiffstats
path: root/compilerplugins/Makefile.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--compilerplugins/Makefile.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/compilerplugins/Makefile.mk b/compilerplugins/Makefile.mk
new file mode 100644
index 000000000..5da6967c1
--- /dev/null
+++ b/compilerplugins/Makefile.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+.PHONY: compilerplugins compilerplugins-clean
+
+ifeq ($(COMPILER_PLUGINS),)
+
+# no support
+
+compilerplugins:
+compilerplugins-clean:
+compilerplugins.clean:
+
+else
+
+ifeq ($(COM_IS_CLANG),TRUE)
+
+compilerplugins:
+ $(MAKE) $(PARALLELISM_OPTION) -f $(SRCDIR)/compilerplugins/Makefile-clang.mk compilerplugins
+
+compilerplugins-clean:
+ $(MAKE) -f $(SRCDIR)/compilerplugins/Makefile-clang.mk compilerplugins-clean
+
+compilerplugins.clean: compilerplugins-clean
+
+endif
+
+endif
+
+# vim: set noet sw=4 ts=4: