summaryrefslogtreecommitdiffstats
path: root/compilerplugins/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'compilerplugins/Makefile')
-rw-r--r--compilerplugins/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/compilerplugins/Makefile b/compilerplugins/Makefile
new file mode 100644
index 000000000..b458116a2
--- /dev/null
+++ b/compilerplugins/Makefile
@@ -0,0 +1,23 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+ifeq ($(BUILD_TYPE),)
+ifeq ($(gb_Side),)
+gb_Side:=host
+endif
+include $(dir $(realpath $(lastword $(MAKEFILE_LIST))))../config_$(gb_Side).mk
+endif
+
+include $(SRCDIR)/compilerplugins/Makefile.mk
+
+all: build
+build: compilerplugins
+clean: compilerplugins-clean
+
+# vim: set noet sw=4 ts=4: