summaryrefslogtreecommitdiffstats
path: root/configmgr/Module_configmgr.mk
diff options
context:
space:
mode:
Diffstat (limited to 'configmgr/Module_configmgr.mk')
-rw-r--r--configmgr/Module_configmgr.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/configmgr/Module_configmgr.mk b/configmgr/Module_configmgr.mk
new file mode 100644
index 000000000..09212d436
--- /dev/null
+++ b/configmgr/Module_configmgr.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,configmgr))
+
+$(eval $(call gb_Module_add_targets,configmgr,\
+ Library_configmgr \
+))
+
+$(eval $(call gb_Module_add_subsequentcheck_targets,configmgr,\
+ JunitTest_configmgr_unoapi \
+))
+
+$(eval $(call gb_Module_add_check_targets,configmgr,\
+ CppunitTest_configmgr_unit \
+))
+
+# vim: set noet sw=4 ts=4: