summaryrefslogtreecommitdiffstats
path: root/cppcanvas/Library_mtfrenderer.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cppcanvas/Library_mtfrenderer.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/cppcanvas/Library_mtfrenderer.mk b/cppcanvas/Library_mtfrenderer.mk
new file mode 100644
index 000000000..ba3d5be3a
--- /dev/null
+++ b/cppcanvas/Library_mtfrenderer.mk
@@ -0,0 +1,41 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,mtfrenderer))
+
+$(eval $(call gb_Library_set_componentfile,mtfrenderer,cppcanvas/source/uno/mtfrenderer,services))
+
+$(eval $(call gb_Library_use_external,mtfrenderer,boost_headers))
+
+$(eval $(call gb_Library_use_libraries,mtfrenderer,\
+ sal \
+ cppu \
+ cppuhelper \
+ comphelper \
+ cppcanvas \
+ basegfx \
+))
+
+$(eval $(call gb_Library_use_sdk_api,mtfrenderer))
+
+$(eval $(call gb_Library_add_exception_objects,mtfrenderer,\
+ cppcanvas/source/uno/uno_mtfrenderer \
+))
+
+# vim: set noet sw=4 ts=4: