summaryrefslogtreecommitdiffstats
path: root/dbaccess/Executable_odbcconfig.mk
diff options
context:
space:
mode:
Diffstat (limited to 'dbaccess/Executable_odbcconfig.mk')
-rw-r--r--dbaccess/Executable_odbcconfig.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/dbaccess/Executable_odbcconfig.mk b/dbaccess/Executable_odbcconfig.mk
new file mode 100644
index 000000000..862c77b3b
--- /dev/null
+++ b/dbaccess/Executable_odbcconfig.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,odbcconfig))
+
+$(eval $(call gb_Executable_set_targettype_gui,odbcconfig,YES))
+
+$(eval $(call gb_Executable_use_libraries,odbcconfig,\
+ comphelper \
+))
+
+$(eval $(call gb_Executable_use_system_win32_libs,odbcconfig,\
+ legacy_stdio_definitions \
+ odbccp32 \
+))
+
+$(eval $(call gb_Library_use_sdk_api,odbcconfig))
+
+$(eval $(call gb_Executable_add_exception_objects,odbcconfig,\
+ dbaccess/win32/source/odbcconfig/odbcconfig \
+))
+
+$(eval $(call gb_Executable_add_default_nativeres,odbcconfig))
+
+# vim: set noet sw=4 ts=4: