summaryrefslogtreecommitdiffstats
path: root/debian/README
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--debian/README83
-rw-r--r--debian/README.Debian307
-rw-r--r--debian/README.Debian-source82
-rw-r--r--debian/README.qa59
4 files changed, 531 insertions, 0 deletions
diff --git a/debian/README b/debian/README
new file mode 100644
index 000000000..01e7967e5
--- /dev/null
+++ b/debian/README
@@ -0,0 +1,83 @@
+LibreOffice build system
+------------------------
+
+Building the packages from source
+=================================
+Overview:
+ apt-get source libreoffice
+ apt-get build-dep libreoffice (to install build dependencies)
+ cd <source directory>
+ debuild
+
+Changing the build behaviour with DEB_BUILD_OPTIONS
+---------------------------------------------------
+These options are supported:
+
+ debug - build with FULL debug symbols. Default is just to build
+ with SMALL ones since the deb otherwise gets too big
+ ((>400M, ca. 1GB I-S))
+
+ ccache - enable the use of ccache during the build. This is highly
+ recommended if you plan on building the package more than
+ once, or doing any development on the packages. Be aware
+ that you need EXTRAPACKAGES="ccache" in /etc/pbuilderrc
+ when trying to build libreoffice with ccache in
+ $DEB_BUILD_OPTIONS under pbuilder (this has no effect
+ on speed, hough because the cache does not persist in
+ pbuilder)
+
+ parallel=<n>
+ - enable n projects to be built in parallel.
+ The log output can get a little confusing, and some projects
+ may fail still. You need to remove config.status if you
+ change this value after interrupting a build.
+
+ lang=<code>
+ - Build only the specified language
+
+ nocheck
+ - disable run of tests when enabled in rules
+
+
+The targets that are built during the package build
+---------------------------------------------------
+
+- targets run during the package build -
+
+unpack - Does prerequisites for the build: packing, unpacking etc.
+
+build - as the name says
+
+install - Copy files from debian/tmp/pkg into the correct locations
+ for the final package layout in debian/libreoffice*
+ where we need to do that here because it affects arch-dep
+ and arch-indep stuff and therefore cannot be done in
+ install-arch / install-indep.
+
+install-arch - installs arch-dependent stuff into the arch-dep. packages
+install-indep - " "-independent " " " "-indep. packages
+
+langpackgs - Installs the language packgs
+helppkgs - Installs the help packages
+
+maintscripts - Generates the maintainer scripts
+
+get-orig-source - gets original source tarballs and unpacks them
+ GIT_BASEURL can be set to a local mirror
+ GIT_BRANCH is the branch to clone from the repos
+ GIT_TAG is tag that should be packed
+ GIT_BRANCH and GIT_TAG can both be master
+
+Building the package from git master
+====================================
+To do a build from git master, do:
+ mkdir libreoffice-git
+ cd libreoffice-git
+ git clone https://salsa.debian.org/libreoffice-team/libreoffice/libreoffice.git debian
+ ./debian/rules unpack GIT_BRANCH=master GIT_TAG=master SOURCE_TARBALLS=n
+ dpkg-buildpackage
+
+Build system file layout
+========================
+debian/scripts:
+ Directory containing various debian-specific build-related scripts.
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 000000000..c27c3d5c6
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,307 @@
+ Readme for libreoffice package for Debian
+ --------------------------------------------
+
+Contents
+========
+Introduction
+Quick start
+Printer setup
+ Native CUPS support
+ Non-CUPS systems
+Language support
+ Spellcheck dictionaries, Hyphenation patterns and Thesauri
+ Help packages
+Display and crashing problems
+ X server crashes
+Font problems
+ Why are the menu fonts smaller than in older versions?
+ Changing the default user interface font typeface for non-KDE/Gnome desktops
+Disabling the splash screen
+AppArmor problems
+More information about LibreOffice in Debian
+
+
+Introduction
+============
+Welcome to the LibreOffice packages for the Debian distribution. These
+packages are of the release of LibreOffice with the following
+modifications:
+
+ * Packaged as libreoffice-core (architecture-dependent core files),
+ libreoffice-common (architecture-independent common files),
+ libreoffice-{calc,writer,draw,impress,base} (the LibreOffice modules)
+ libreoffice-l10n-<lang> and libreoffice-help-<lang> and
+ other subpackages (-filters-* for lesser used filters, -gtk/-gnome/-kde,
+ ttf-opensymbol for the OpenSymbol font, ...).
+
+ * Integration with other Debian packages:
+ - Global desktop integration for all users for KDE and Gnome desktops.
+ Menu entries for all window managers that support the Debian 'menu'
+ package.
+
+ * Some extra features not yet present in official releases:
+ - Many of the patches included in the Ximian edition
+
+ * Extra documentation - this README and man pages.
+
+
+Quick start
+===========
+
+To start using LibreOffice, execute the command
+
+ libreoffice
+
+as the user which you wish to start LibreOffice as. This will create the
+necessary user files in ~/.libreoffice/3 for you. Alternatively, you
+can start LibreOffice from the menus, if you have the menu package
+installed/use KDE or GNOME.
+
+Printing
+========
+
+Printing on CUPS systems
+------------------------
+The Debian packages include native CUPS support from version 1.1.1-3. This
+is standard in all OpenOffice.org versions since 2.0.
+When LibreOffice detects a CUPS system, it will download printer settings for
+all CUPS queues, and these can be set from within the printer properties dialog.
+
+If you wish to add additional filters or print commands, you can add them
+using 'spadmin'. Note that the 'Add a printer' option is disabled - you
+should add printers using your favourite CUPS frontend.
+
+When creating a new document, LibreOffice will use the default paper size of
+your default CUPS printer queue. If your new documents have the wrong paper
+size, please check the configuration of your printer.
+
+Non-CUPS systems (lpr, lprng, SAL_DISABLE_CUPS=1)
+---------------------------------
+There is a tool supplied with LibreOffice for setting up printers. You can
+execute this with the command
+
+ /usr/lib/openoffice/program/spadmin
+
+To change the page size and other default settings on non-CUPS systems,
+modify /etc/openoffice/psprint.conf. The settings are documented in there.
+
+Language support
+================
+You can get foreign language support by installing the
+libreoffice-l10n-<lang> package for your language. You will also need the
+'locales' (or belocs-locales-data for some locales, alternatively locales-all
+if you want all locales) package installed.
+The user interface language is selected according to your locale(1) settings.
+
+To change the user interface language for all users, run
+
+ dpkg-reconfigure locales
+
+[ This is not needed when you install locales-all ]
+
+To change the language for just one user, you must arrange for the LC_MESSAGES
+or LANG environment variable to be set. You can list all available locales
+with the command 'locale -a'.
+For example, to run LibreOffice in German from the command line:
+
+ LANG=de_DE libreoffice
+
+Spellcheck dictionaries, Hyphenation patterns and Thesauri
+----------------------------------------------------------
+Currently, there are dictionaries available for Afrikaans, Arabic, Armenian,
+Bulgarian, Catalan, Croatian, Czech, Danish, Dutch, English (AUS/GB/US),
+Esperanto, Estonian, Farsi, Finnish, French, Galician, German (DE/CH/AT),
+Greek, Hebrew, Hungarian, Irish (Gaeilge), Italian, Kurdish, Latvian,
+Lithuanian, Manx Gaelic, Norwegian Bokmal, Norwegian Nynorsk, Polish,
+Portuguese, Portuguese (Brazilian), Russian, Scots Gaelic, Slovak, Slovenian,
+Spanish, Swahili, Swedish, Thai, Ukrainian and Uzbek.
+Dictionaries are packaged as myspell-<lang> (or, for newer ones improved
+for hunspell hunspell-<lang>).
+
+Currently, there are thesauri available for Czech, English (AUS/GB/US),
+German (DE/CH), Italian, Polish and Slovak.
+Thesauri are packaged as mythes-<lang>
+
+Currently, there are hyphenation patterns available for English (USA),
+Croatian, Estonian, German, Hungarian, Italian, Polish, Slovenian and
+Lithuanian.
+Hyphenation patterns are packaged as hyphen-<lang>.
+
+Help packages
+-------------
+Currently, there are localized help packages available for
+Bulgarian, Chinese, Czech, Danish, Dutch, English (GB), English (USA),
+Estonian, French, Galician, German, Hungarian, Italian, Japanese, Khmer,
+Macedonian, Polish, Portuguese (Brazil), Russian, Slovakian, Slovenian and
+Spanish and Swedish.
+They are packaged as libreoffice-help-<lang>.
+
+Problems
+================================
+
+Here are some problems that have been reported with this version. If you do
+not see your problem here, please check for open bug reports:
+
+ http://bugs.debian.org/debian-openoffice@lists.debian.org
+
+1. If you are using NFS mounted file systems, you should make sure that locking
+is functioning:
+
+ 'Make sure NFS lockd/statd is running on the client, or mount the NFS export
+ with the 'nolock' option.
+
+ If /usr gets mounted from an initrd, check 'ps' output once the system is
+ fully booted to ensure that you see a [lockd] kernel process, or an
+ 'rpc.lockd' / 'rpc.statd' userspace process.
+
+ If not, just issue your mount command again (no need to even -o remount it
+ seems!) and run /etc/init.d/nfs-common restart.' (Thanks to Gavin Hamill)
+
+ See this mailing list thread for more information:
+ http://lists.debian.org/debian-openoffice/2004/debian-openoffice-200402/msg00223.html
+
+X server crash with Matrox cards
+--------------------------------
+If your X server is using the mga driver, you may find that your X server
+crashes. You can work around this problem by adding this line to the mga
+Device section:
+
+ Option "XaaNoScreenToScreenColorExpandFill"
+
+There is a bug already open against xserver-xfree86 for this problem. Thanks
+to Philip Armstrong for this information.
+
+LibreOffice crash with nVidia cards
+--------------------------------------
+It seems that LibreOffice can trigger some obscure bugs in the X server
+drivers for Nvidia cards too, especially if you have more than one processor.
+Try updating your drivers to the latest version.
+
+Moreover LibreOffice may hang and takes X with it when RenderAccel
+is enabled when using the proprietary nVidia Drivers. Disabling this option
+helps then.
+
+Font problems
+=============
+
+Why are the menu fonts smaller than in older versions?
+------------------------------------------------------
+This is caused by a change in the way LibreOfffice interprets your X server DPI
+setting.
+This setting, when correctly configured, means that software can display text
+at its true size on the display.
+
+The official OpenOffice.org version assumes that anyone who has their X server
+configured with a DPI of less than 96 has not actually configured it at all,
+and sets it back to 96. Unfortunately, this has the side effect that
+displays with a lower DPI setting, such as some LCD laptop displays, cannot
+display the page at its true size.
+
+So you can fix this by correctly setting the DPI for your X server. Gnome
+users will find that it is set to 96 DPI by default; others may need to edit
+their X server configuration.
+
+The best way to get the correct DPI setting is to add a 'DisplaySize' entry to
+the Monitor section. From the XF86Config-4 man page:
+
+ DisplaySize width height
+ This optional entry gives the width and height, in millimetres, of the
+ picture area of the monitor. If given this is used to calculate the
+ horizontal and vertical pitch (DPI) of the screen.
+
+If you set this value correctly, X will calculate and use the correct DPI
+setting, even if you use several different display resolutions.
+
+From Nikita V. Youshchenko <yoush at cs.msu.su>:
+
+- Many display manager configurations pass the option "-dpi 100" to the X
+ server by default, overriding any autodetected DPI. This has to be removed
+ for DisplaySize to work. The file that you need to edit varies depending on
+ the way your X server is started:
+ xdm: /etc/X11/xdm/Xservers
+ kdm: /etc/kde3/kdm/Xservers
+ gdm: /etc/gdm/gdm.conf
+ startx: /etc/X11/xinit/xserverrc
+
+- Gnome's gconf overrides the autodetected DPI, by setting Xft.dpi to a value
+ entered in configuration dialog, 96 by default. I don't know what is
+ the clean fix for this. Perhaps it should be fixed on the Gnome side.
+
+From Juergen Kreileder <jk at blackdown.de>:>
+
+- Note that with most recent graphics cards and monitors XFree86 is able to
+ get the monitor size (and thus the correct dpi value) through ddc.
+ (**) NVIDIA(0): Validated modes for display device DFP-0:
+ (**) NVIDIA(0): Default mode "1600x1200": 189.0 MHz, 87.5 kHz, 70.0 Hz
+ (II) NVIDIA(0): Virtual screen size determined to be 1600 x 1200
+ (--) NVIDIA(0): Display dimensions: (410, 310) mm
+ (--) NVIDIA(0): DPI set to (99, 98)
+ (That's with the proprietary NVIDIA drivers but other XFree86 drivers have
+ that support too.)
+
+If you use KDE or Gnome, LibreOffice will use the same font face and size as
+your desktop environment. If you use another window manager, you can either
+let it pick a default font itself, or change the font to be used (see next
+section), or set the OOO_FORCE_DESKTOP environment variable to
+kde (for kde3)/kde4 or gnome, to use KDE or Gnome settings respectively.
+
+Changing the default user interface font typeface for non-KDE/Gnome desktops
+----------------------------------------------------------------------------
+If you do not want to use KDE or Gnome settings and want to change font sizes
+within LibreOffice, you can configure the user interface font as follows:
+
+- Font size -
+
+You can change the font scaling using the user interface:
+
+ Tools Menu -> Options -> View -> Scale
+
+- Font typeface -
+
+You can change the default font typeface by replacing it with a different font
+installed on your system. This can be done using the font replacement function.
+Choose Tools - Options - LibreOffice - Font Replacement to access this
+function.
+
+To change the font of the LibreOffice user interface, you have to replace
+the default font "Andale Sans UI" with another font and mark the "always"
+setting for this replacement. "Andale Sans UI" is not selectable and has to be
+typed in. The replacement font has to be a font which supports the requested
+locale ( e.g for Korean language the replacement font has to be a font
+including Korean characters).
+
+Refer to the LibreOffice Help for a detailed explanation of the font
+replacement dialog.
+
+Disabling the splash screen
+===========================
+If you don't like the splash screen staying in front of other windows while
+LibreOffice is loading, you can disable it by editing
+/etc/openoffice/sofficerc. Change Logo=1 to Logo=0.
+
+AppArmor problems
+=================
+
+LibreOffice in Debian ships with AppArmor profiles:
+
+ /etc/apparmor.d/usr.lib.libreoffice.*
+
+To debug issues with these AppArmor profiles, see:
+
+ https://wiki.debian.org/AppArmor/Debug
+
+If you are using custom settings such as a custom env:UserInstallation
+directory, you may need to adjust them to match your local setup.
+In this example, you would need to add your custom
+env:UserInstallation to @{libo_user_dirs} in the
+usr.lib.libreoffice.program.soffice.bin profile.
+
+More information about LibreOffice in Debian
+===============================================
+Please read the official README.gz (in the same directory as this file), too.
+
+If you have questions, either post to our the mailing list:
+
+ http://lists.debian.org/debian-openoffice
+
+The Debian LibreOffice team
diff --git a/debian/README.Debian-source b/debian/README.Debian-source
new file mode 100644
index 000000000..7b9f523b2
--- /dev/null
+++ b/debian/README.Debian-source
@@ -0,0 +1,82 @@
+Package directory modes
+=======================
+The packages can be built directly from a set of git checkouts (vcs mode),
+or from a set of release tarballs (tarball mode).
+
+Vcs mode is useful if you want to work on libreoffice during the development
+cycle. You can check out the latest sources and track them while you make
+changes.
+
+Tarball mode is used to prepare packages of official libreoffice releases
+from the tarballs created by upstream.
+
+Source package creation steps for tarball mode
+==============================================
+The .orig.tar.gz consists of the (separate) source tarballs available
+from The Document Foundation from
+http://download.documentfoundation.org/libreoffice/src/<version/
+
+The libreoffice-x.y.z.a.tar.xz is taken verbatim as original tarball:
+$ ln -s libreoffice-x.y.z.a.tar.xz libreoffice_x.y.z.orig.tar.xz
+$ tar xfvJ libreoffice-x.y.z.a.tar.xz
+
+For a full build you also need helpcontent2 and translations (and the external
+modules' tarballs) which normally are git submodules and/or downloaded during
+the build.
+
+As dpkg-source expects e.g. helpcontent2 as a subdir we can't directly
+symlink (as the tarball contains libreoffice-x.y.z.a/helpcontent2).
+We need to create them manually/repack them:
+
+$ tar xfvJ libreoffice-helpcontent2-x.y.z.a.tar.xz
+$ tar xfvJ libreoffice-translations-x.y.z.a.tar.xz
+$ cd libreoffice-x.y.z.a
+$ for i in helpcontent2 translations tarballs; do \
+ tar cfvJ ../libreoffice_5.2.1.orig-$i.tar.xz $i; \
+ done
+
+The get-orig-source debian/rules target does this with our custom
+mk-origtargz script.
+
+Given those files are not in the tarballs above they need to be removed
+as otherwise dpkg complains
+$ rm ChangeLog-*
+
+We also need the "tarballs".
+A standard upstream build downloads it during the build, but we neither can't nor want it here of course. So:
+
+$ rm -rf tarballs
+$ mkdir -p tarballs
+$ ./autogen.sh $(filter-out --disable-fetch-external,$(CONFIGURE_FLAGS)) --with-all-tarballs
+$ make download gb_LO_VER=<version>
+
+or base on an old version and add/remove the files manually and/or symlink
+to the old version if this didn't change - see git diff of download.lst. This
+is even better given we probably want to add only needed stuff there, and not
+all tarballs (most of those we don't use)
+
+See the "Format: 3.0 (quilt)" section dpkg-source(1) for more details.
+
+Package directory layout - vcs mode
+===================================
+
+In vcs mode we are working directly from checkouts of the libreoffice sources.
+
+We pull in sources to these places:
+
+ "top" directory - checkout of LO's "core" repo
+ debian - git packaging repository from pkg-openoffice project on alioth
+ helpcontent2 - checkout of LO's "help" repo (git submodule)
+ translations - checkout of LO's "translations" repo (git submodule)
+ tarballs - see above in tarball mode
+
+$ git clone git://gerrit.libreoffice.org/core
+$ cd core
+$ git submodule init
+
+(maybe remove dictionaries again, see .git/config, we don't need it here.)
+
+./g pull -r (git pull -r, but also does the necessary steps for the submodules)
+
+For tarballs/, see above
+
diff --git a/debian/README.qa b/debian/README.qa
new file mode 100644
index 000000000..3da75a9fe
--- /dev/null
+++ b/debian/README.qa
@@ -0,0 +1,59 @@
+LibreOffice QA Tools
+
+smoketest
+=========
+
+smoketest executes a set of macros that create a minimal document in
+each of LibreOffice's applications, tests cut&paste and
+saving/loading in various formats.
+
+Invoke it as oosmoketest.
+
+This program manipulates the LibreOffice user configuration, USE IT
+WITH A DEDICATED USER ACCOUNT if you value your settings.
+
+qadevOOo
+========
+
+qadevOOo is a framework for executing tests for the LibreOffice
+API. It is documented at
+http://qa.openoffice.org/qadevOOo_doc/user-guide.html
+
+Predefined properties files exist in /usr/lib/openoffice/qadevOOo.
+
+Invoke it like e.g:
+
+ ootestapi -ini /usr/lib/openoffice/qadevOOo/java.props -o sd.SdMasterPage
+
+That properties files specify AppExecutionCommand, i.e. an office will
+be started if necessary. Some tests, however seem to work better if
+the office was started manually, as written in the user guide.
+
+ /usr/lib/openoffice/program/soffice "-accept=socket,host=localhost,port=8100;urp;"
+
+Use this invocation and not ooffice to prevent interference with the
+quickstarter code.
+
+testtool
+========
+
+testtool is a framework for executing tests by automating actions in
+LibreOffice's user interface. It is documented at
+http://qa.openoffice.org/qatesttool/index.html
+
+Test scripts for testtool are available in the
+libreoffice-qa-ui-tests package.
+
+Start it as ootesttool.
+
+If you're starting it for the first time, create a profile in
+Extras->Settings where you specify the location of test scripts and
+output path for log files. The default values point to the scripts
+from the libreoffice-qa-ui-tests package, so simply giving a name
+to the profile and pressing the "New" button is enough.
+
+Then open a test script and press F5 to start the test.
+
+Some test scripts may change your LibreOffice user
+configuration. USE IT WITH A DEDICATED USER ACCOUNT if you value your
+settings.