summaryrefslogtreecommitdiffstats
path: root/desktop/CustomTarget_desktop_unopackages_install.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/CustomTarget_desktop_unopackages_install.mk')
-rw-r--r--desktop/CustomTarget_desktop_unopackages_install.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/desktop/CustomTarget_desktop_unopackages_install.mk b/desktop/CustomTarget_desktop_unopackages_install.mk
new file mode 100644
index 000000000..f16845fe1
--- /dev/null
+++ b/desktop/CustomTarget_desktop_unopackages_install.mk
@@ -0,0 +1,19 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,desktop/unopackages_install))
+
+$(call gb_CustomTarget_get_target,desktop/unopackages_install) : | \
+ $(call gb_CustomTarget_get_workdir,desktop/unopackages_install)/uno_packages/cache/uno_packages
+
+$(call gb_CustomTarget_get_workdir,desktop/unopackages_install)/uno_packages/cache/uno_packages : | \
+ $(call gb_CustomTarget_get_workdir,desktop/unopackages_install)/.dir
+ mkdir -p $@
+
+# vim: set noet sw=4 ts=4: