summaryrefslogtreecommitdiffstats
path: root/desktop/Executable_sdraw.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/Executable_sdraw.mk')
-rw-r--r--desktop/Executable_sdraw.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/desktop/Executable_sdraw.mk b/desktop/Executable_sdraw.mk
new file mode 100644
index 000000000..164b65876
--- /dev/null
+++ b/desktop/Executable_sdraw.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,sdraw))
+
+$(eval $(call gb_Executable_set_targettype_gui,sdraw,YES))
+
+$(eval $(call gb_Executable_add_ldflags,sdraw,\
+ /ENTRY:wWinMainCRTStartup \
+))
+
+$(eval $(call gb_Executable_use_static_libraries,sdraw,\
+ winlauncher \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,sdraw,\
+ desktop/win32/source/applauncher/sdraw \
+))
+
+$(eval $(call gb_Executable_add_nativeres,sdraw,sdraw/launcher))
+
+$(eval $(call gb_Executable_add_default_nativeres,sdraw,$(PRODUCTNAME) Draw))
+
+# vim: set ts=4 sw=4 et: