summaryrefslogtreecommitdiffstats
path: root/desktop/Executable_smath.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/Executable_smath.mk')
-rw-r--r--desktop/Executable_smath.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/desktop/Executable_smath.mk b/desktop/Executable_smath.mk
new file mode 100644
index 000000000..797354d47
--- /dev/null
+++ b/desktop/Executable_smath.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,smath))
+
+$(eval $(call gb_Executable_set_targettype_gui,smath,YES))
+
+$(eval $(call gb_Executable_add_ldflags,smath,\
+ /ENTRY:wWinMainCRTStartup \
+))
+
+$(eval $(call gb_Executable_use_static_libraries,smath,\
+ winlauncher \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,smath,\
+ desktop/win32/source/applauncher/smath \
+))
+
+$(eval $(call gb_Executable_add_nativeres,smath,smath/launcher))
+
+$(eval $(call gb_Executable_add_default_nativeres,smath,$(PRODUCTNAME) Math))
+
+# vim: set ts=4 sw=4 et: