summaryrefslogtreecommitdiffstats
path: root/desktop/Extension_test-crashextension.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/Extension_test-crashextension.mk')
-rw-r--r--desktop/Extension_test-crashextension.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/desktop/Extension_test-crashextension.mk b/desktop/Extension_test-crashextension.mk
new file mode 100644
index 000000000..aa525f72b
--- /dev/null
+++ b/desktop/Extension_test-crashextension.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Extension_Extension,test-crashextension,desktop/test/deployment/crashextension,nodeliver))
+
+$(eval $(call gb_Extension_add_file,test-crashextension,platform.components,$(call gb_Rdb_get_target,crashextension)))
+
+$(eval $(call gb_Extension_add_files,test-crashextension,, \
+ $(SRCDIR)/desktop/test/deployment/crashextension/Addons.xcu \
+ $(SRCDIR)/desktop/test/deployment/crashextension/ProtocolHandler.xcu \
+ $(SRCDIR)/desktop/test/deployment/crashextension/crash.png \
+))
+
+$(eval $(call gb_Extension_add_libraries,test-crashextension, \
+ crashextension \
+))
+
+# vim: set noet sw=4 ts=4: