summaryrefslogtreecommitdiffstats
path: root/desktop/Library_migrationoo2.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/Library_migrationoo2.mk')
-rw-r--r--desktop/Library_migrationoo2.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/desktop/Library_migrationoo2.mk b/desktop/Library_migrationoo2.mk
new file mode 100644
index 000000000..2314d5697
--- /dev/null
+++ b/desktop/Library_migrationoo2.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,migrationoo2))
+
+$(eval $(call gb_Library_use_external,migrationoo2,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,migrationoo2))
+
+$(eval $(call gb_Library_use_libraries,migrationoo2,\
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ $(if $(ENABLE_JAVA), \
+ jvmfwk) \
+ sal \
+ tl \
+ utl \
+))
+
+$(eval $(call gb_Library_set_componentfile,migrationoo2,desktop/source/migration/services/migrationoo2,services))
+
+$(eval $(call gb_Library_add_exception_objects,migrationoo2,\
+ desktop/source/migration/services/basicmigration \
+ $(if $(ENABLE_JAVA), \
+ desktop/source/migration/services/jvmfwk) \
+ desktop/source/migration/services/wordbookmigration \
+))
+
+# vim: set ts=4 sw=4 et: