summaryrefslogtreecommitdiffstats
path: root/desktop/Library_migrationoo3.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/Library_migrationoo3.mk')
-rw-r--r--desktop/Library_migrationoo3.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/desktop/Library_migrationoo3.mk b/desktop/Library_migrationoo3.mk
new file mode 100644
index 000000000..10a63e3d8
--- /dev/null
+++ b/desktop/Library_migrationoo3.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,migrationoo3))
+
+$(eval $(call gb_Library_use_sdk_api,migrationoo3))
+
+$(eval $(call gb_Library_use_libraries,migrationoo3,\
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+ utl \
+))
+
+$(eval $(call gb_Library_set_componentfile,migrationoo3,desktop/source/migration/services/migrationoo3,services))
+
+$(eval $(call gb_Library_add_exception_objects,migrationoo3,\
+ desktop/source/migration/services/oo3extensionmigration \
+))
+
+# vim: set ts=4 sw=4 et: