summaryrefslogtreecommitdiffstats
path: root/desktop/Package_branding_custom.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/Package_branding_custom.mk')
-rw-r--r--desktop/Package_branding_custom.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/desktop/Package_branding_custom.mk b/desktop/Package_branding_custom.mk
new file mode 100644
index 000000000..c2b6181f9
--- /dev/null
+++ b/desktop/Package_branding_custom.mk
@@ -0,0 +1,20 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Package_Package,desktop_branding_custom,$(CUSTOM_BRAND_DIR)))
+
+$(eval $(call gb_Package_add_files,desktop_branding_custom,$(LIBO_ETC_FOLDER),\
+ $(filter $(BRAND_INTRO_IMAGES),$(CUSTOM_BRAND_IMAGES)) \
+))
+
+$(eval $(call gb_Package_add_files,desktop_branding_custom,$(LIBO_ETC_FOLDER)/shell,\
+ $(filter-out $(BRAND_INTRO_IMAGES),$(CUSTOM_BRAND_IMAGES)) \
+))
+
+# vim: set noet sw=4 ts=4: