summaryrefslogtreecommitdiffstats
path: root/embeddedobj/test/MainThreadExecutor/makefile.mk
diff options
context:
space:
mode:
Diffstat (limited to 'embeddedobj/test/MainThreadExecutor/makefile.mk')
-rw-r--r--embeddedobj/test/MainThreadExecutor/makefile.mk58
1 files changed, 58 insertions, 0 deletions
diff --git a/embeddedobj/test/MainThreadExecutor/makefile.mk b/embeddedobj/test/MainThreadExecutor/makefile.mk
new file mode 100644
index 000000000..a8fef803e
--- /dev/null
+++ b/embeddedobj/test/MainThreadExecutor/makefile.mk
@@ -0,0 +1,58 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ=..$/..
+
+PRJNAME=embeddedobj
+TARGET=mainexec
+LIBTARGET=NO
+USE_DEFFILE=TRUE
+
+# --- Settings -----------------------------------------------------------
+
+.INCLUDE : settings.mk
+
+# --- Files --------------------------------------------------------
+
+SHL1TARGET= $(TARGET)
+
+SHL1IMPLIB= i$(TARGET)
+SHL1OBJS= \
+ $(SLO)$/xexecutor.obj\
+ $(SLO)$/register.obj
+
+EXCEPTIONSFILES= \
+ $(SLO)$/xexecutor.obj\
+ $(SLO)$/register.obj
+
+SHL1STDLIBS=\
+ $(SALLIB)\
+ $(VCLLIB)\
+ $(CPPULIB)\
+ $(CPPUHELPERLIB)
+
+SHL1DEF= $(MISC)$/$(SHL1TARGET).def
+
+DEF1NAME= $(SHL1TARGET)
+DEF1EXPORTFILE= exports.dxp
+
+# --- Targets -------------------------------------------------------------
+
+.INCLUDE : target.mk
+
+