summaryrefslogtreecommitdiffstats
path: root/embeddedobj/test/mtexecutor/makefile.mk
diff options
context:
space:
mode:
Diffstat (limited to 'embeddedobj/test/mtexecutor/makefile.mk')
-rw-r--r--embeddedobj/test/mtexecutor/makefile.mk69
1 files changed, 69 insertions, 0 deletions
diff --git a/embeddedobj/test/mtexecutor/makefile.mk b/embeddedobj/test/mtexecutor/makefile.mk
new file mode 100644
index 000000000..061f1ecb0
--- /dev/null
+++ b/embeddedobj/test/mtexecutor/makefile.mk
@@ -0,0 +1,69 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ=..$/..
+
+PRJNAME=embeddedobj
+TARGET=mainthrexec
+
+
+# --- Settings -----------------------------------------------------
+
+.INCLUDE : settings.mk
+
+LIBTARGET=NO
+USE_DEFFILE=NO
+INCPRE+=$(ATL_INCLUDE)
+
+# --- Files --------------------------------------------------------
+
+SHL1TARGET= $(TARGET)
+
+SHL1IMPLIB= i$(TARGET)
+
+SLOFILES = \
+ $(SLO)$/mainthreadexecutor.obj\
+ $(SLO)$/bitmapcreator.obj\
+ $(SLO)$/mteregister.obj
+
+EXCEPTIONSFILES = \
+ $(SLO)$/mainthreadexecutor.obj\
+ $(SLO)$/bitmapcreator.obj\
+ $(SLO)$/mteregister.obj
+
+SHL1OBJS= $(SLOFILES)
+
+SHL1STDLIBS=\
+ $(SALLIB)\
+ $(CPPULIB)\
+ $(CPPUHELPERLIB)\
+ $(TOOLSLIB)\
+ $(VCLLIB)\
+ itk.lib
+
+DEF1EXPORTFILE= exports.dxp
+
+SHL1DEF= $(MISC)$/$(SHL1TARGET).def
+
+DEF1NAME= $(SHL1TARGET)
+
+
+# --- Targets -------------------------------------------------------
+
+.INCLUDE : target.mk
+