summaryrefslogtreecommitdiffstats
path: root/external/freetype/ExternalProject_freetype.mk
diff options
context:
space:
mode:
Diffstat (limited to 'external/freetype/ExternalProject_freetype.mk')
-rw-r--r--external/freetype/ExternalProject_freetype.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/external/freetype/ExternalProject_freetype.mk b/external/freetype/ExternalProject_freetype.mk
new file mode 100644
index 000000000..2a61ac7d7
--- /dev/null
+++ b/external/freetype/ExternalProject_freetype.mk
@@ -0,0 +1,38 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalProject_ExternalProject,freetype))
+
+$(eval $(call gb_ExternalProject_register_targets,freetype,\
+ build \
+))
+
+$(call gb_ExternalProject_get_state_target,freetype,build) :
+ $(call gb_Trace_StartRange,freetype,EXTERNAL)
+ $(call gb_ExternalProject_run,build,\
+ $(gb_RUN_CONFIGURE) ./configure \
+ --disable-shared \
+ --with-pic \
+ --without-zlib \
+ --without-brotli \
+ --without-bzip2 \
+ --without-harfbuzz \
+ --without-png \
+ --prefix=$(call gb_UnpackedTarball_get_dir,freetype/instdir) \
+ $(gb_CONFIGURE_PLATFORMS) \
+ CFLAGS="$(CFLAGS) \
+ $(call gb_ExternalProject_get_build_flags,freetype) \
+ $(gb_VISIBILITY_FLAGS) \
+ $(gb_EMSCRIPTEN_CPPFLAGS)" \
+ LDFLAGS="$(call gb_ExternalProject_get_link_flags,freetype)" \
+ && $(MAKE) install \
+ && touch $@ )
+ $(call gb_Trace_EndRange,freetype,EXTERNAL)
+
+# vim: set noet sw=4 ts=4: