summaryrefslogtreecommitdiffstats
path: root/external/harfbuzz
diff options
context:
space:
mode:
Diffstat (limited to 'external/harfbuzz')
-rw-r--r--external/harfbuzz/ExternalProject_harfbuzz.mk58
-rw-r--r--external/harfbuzz/Makefile7
-rw-r--r--external/harfbuzz/Module_harfbuzz.mk17
-rw-r--r--external/harfbuzz/README1
-rw-r--r--external/harfbuzz/UnpackedTarball_harfbuzz.mk21
5 files changed, 104 insertions, 0 deletions
diff --git a/external/harfbuzz/ExternalProject_harfbuzz.mk b/external/harfbuzz/ExternalProject_harfbuzz.mk
new file mode 100644
index 000000000..f7767f7a7
--- /dev/null
+++ b/external/harfbuzz/ExternalProject_harfbuzz.mk
@@ -0,0 +1,58 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalProject_ExternalProject,harfbuzz))
+
+$(eval $(call gb_ExternalProject_use_autoconf,harfbuzz,build))
+
+$(eval $(call gb_ExternalProject_register_targets,harfbuzz,\
+ build \
+))
+
+$(eval $(call gb_ExternalProject_use_externals,harfbuzz,\
+ icu \
+ graphite \
+))
+
+$(call gb_ExternalProject_get_state_target,harfbuzz,build) :
+ $(call gb_Trace_StartRange,harfbuzz,EXTERNAL)
+ $(call gb_ExternalProject_run,build,\
+ $(if $(CROSS_COMPILING),ICU_CONFIG=$(SRCDIR)/external/icu/cross-bin/icu-config) \
+ $(if $(SYSTEM_ICU),,ICU_CONFIG=$(SRCDIR)/external/icu/cross-bin/icu-config) \
+ GRAPHITE2_CFLAGS="$(GRAPHITE_CFLAGS)" \
+ GRAPHITE2_LIBS="$(GRAPHITE_LIBS)" \
+ $(gb_RUN_CONFIGURE) ./configure \
+ --enable-static \
+ --disable-shared \
+ --disable-gtk-doc \
+ --with-pic \
+ --with-icu=builtin \
+ --with-freetype=no \
+ --with-fontconfig=no \
+ --with-cairo=no \
+ --with-glib=no \
+ --with-graphite2=yes \
+ $(if $(verbose),--disable-silent-rules,--enable-silent-rules) \
+ $(if $(gb_FULLDEPS),,--disable-dependency-tracking) \
+ --libdir=$(call gb_UnpackedTarball_get_dir,harfbuzz/src/.libs) \
+ $(gb_CONFIGURE_PLATFORMS) \
+ CXXFLAGS=' \
+ $(if $(filter ANDROID,$(OS)),-DHB_NO_MMAP=1,) \
+ $(call gb_ExternalProject_get_build_flags,harfbuzz) \
+ $(if $(ENABLE_RUNTIME_OPTIMIZATIONS),,-frtti) \
+ $(CXXFLAGS) $(CXXFLAGS_CXX11) \
+ $(ICU_UCHAR_TYPE) \
+ $(if $(filter LINUX,$(OS)),-fvisibility=hidden)' \
+ LDFLAGS="$(call gb_ExternalProject_get_link_flags,harfbuzz)" \
+ MAKE=$(MAKE) \
+ && (cd $(EXTERNAL_WORKDIR)/src && $(MAKE) lib) \
+ )
+ $(call gb_Trace_EndRange,harfbuzz,EXTERNAL)
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/harfbuzz/Makefile b/external/harfbuzz/Makefile
new file mode 100644
index 000000000..e4968cf85
--- /dev/null
+++ b/external/harfbuzz/Makefile
@@ -0,0 +1,7 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+
+module_directory:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+include $(module_directory)/../../solenv/gbuild/partial_build.mk
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/harfbuzz/Module_harfbuzz.mk b/external/harfbuzz/Module_harfbuzz.mk
new file mode 100644
index 000000000..ffbadd710
--- /dev/null
+++ b/external/harfbuzz/Module_harfbuzz.mk
@@ -0,0 +1,17 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,harfbuzz))
+
+$(eval $(call gb_Module_add_targets,harfbuzz,\
+ ExternalProject_harfbuzz \
+ UnpackedTarball_harfbuzz \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/harfbuzz/README b/external/harfbuzz/README
new file mode 100644
index 000000000..149da5566
--- /dev/null
+++ b/external/harfbuzz/README
@@ -0,0 +1 @@
+HarfBuzz is an OpenType text shaping engine. From [https://harfbuzz.github.io/].
diff --git a/external/harfbuzz/UnpackedTarball_harfbuzz.mk b/external/harfbuzz/UnpackedTarball_harfbuzz.mk
new file mode 100644
index 000000000..9bc9e326b
--- /dev/null
+++ b/external/harfbuzz/UnpackedTarball_harfbuzz.mk
@@ -0,0 +1,21 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,harfbuzz))
+
+$(eval $(call gb_UnpackedTarball_set_tarball,harfbuzz,$(HARFBUZZ_TARBALL),,harfbuzz))
+
+$(eval $(call gb_UnpackedTarball_update_autoconf_configs,harfbuzz))
+
+$(eval $(call gb_UnpackedTarball_set_patchlevel,harfbuzz,0))
+
+$(eval $(call gb_UnpackedTarball_add_patches,harfbuzz, \
+))
+
+# vim: set noet sw=4 ts=4: