summaryrefslogtreecommitdiffstats
path: root/external/libexttextcat/StaticLibrary_libexttextcat.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--external/libexttextcat/StaticLibrary_libexttextcat.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/external/libexttextcat/StaticLibrary_libexttextcat.mk b/external/libexttextcat/StaticLibrary_libexttextcat.mk
new file mode 100644
index 000000000..1e70f8501
--- /dev/null
+++ b/external/libexttextcat/StaticLibrary_libexttextcat.mk
@@ -0,0 +1,25 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_StaticLibrary_StaticLibrary,libexttextcat))
+
+$(eval $(call gb_StaticLibrary_use_unpacked,libexttextcat,libexttextcat))
+
+$(eval $(call gb_StaticLibrary_set_warnings_disabled,libexttextcat))
+
+$(eval $(call gb_StaticLibrary_add_generated_cobjects,libexttextcat,\
+ UnpackedTarball/libexttextcat/src/common \
+ UnpackedTarball/libexttextcat/src/fingerprint \
+ UnpackedTarball/libexttextcat/src/textcat \
+ UnpackedTarball/libexttextcat/src/wg_mempool \
+ UnpackedTarball/libexttextcat/src/utf8misc \
+))
+
+
+# vim: set noet sw=4 ts=4: