summaryrefslogtreecommitdiffstats
path: root/filter/Library_odfflatxml.mk
diff options
context:
space:
mode:
Diffstat (limited to 'filter/Library_odfflatxml.mk')
-rw-r--r--filter/Library_odfflatxml.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/filter/Library_odfflatxml.mk b/filter/Library_odfflatxml.mk
new file mode 100644
index 000000000..176530035
--- /dev/null
+++ b/filter/Library_odfflatxml.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,odfflatxml))
+
+$(eval $(call gb_Library_set_componentfile,odfflatxml,filter/source/odfflatxml/odfflatxml,services))
+
+$(eval $(call gb_Library_use_sdk_api,odfflatxml))
+
+$(eval $(call gb_Library_set_include,odfflatxml,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/filter/inc \
+))
+
+$(eval $(call gb_Library_use_libraries,odfflatxml,\
+ xo \
+ tl \
+ ucbhelper \
+ comphelper \
+ cppuhelper \
+ cppu \
+ sal \
+))
+
+$(eval $(call gb_Library_add_exception_objects,odfflatxml,\
+ filter/source/odfflatxml/OdfFlatXml \
+))
+
+# vim: set noet sw=4 ts=4: