summaryrefslogtreecommitdiffstats
path: root/filter/Package_docbook.mk
diff options
context:
space:
mode:
Diffstat (limited to 'filter/Package_docbook.mk')
-rw-r--r--filter/Package_docbook.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/filter/Package_docbook.mk b/filter/Package_docbook.mk
new file mode 100644
index 000000000..6548fd6a1
--- /dev/null
+++ b/filter/Package_docbook.mk
@@ -0,0 +1,27 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Package_Package,filter_docbook,$(SRCDIR)/filter/source/docbook))
+
+$(eval $(call gb_Package_add_files,filter_docbook,$(LIBO_SHARE_FOLDER)/xslt/docbook,\
+ DocBookTemplate.stw \
+ docbooktosoffheadings.xsl \
+ sofftodocbookheadings.xsl \
+))
+
+# vim: set noet sw=4 ts=4: