summaryrefslogtreecommitdiffstats
path: root/i18npool/Executable_genindex_data.mk
diff options
context:
space:
mode:
Diffstat (limited to 'i18npool/Executable_genindex_data.mk')
-rw-r--r--i18npool/Executable_genindex_data.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/i18npool/Executable_genindex_data.mk b/i18npool/Executable_genindex_data.mk
new file mode 100644
index 000000000..e96e7dc8e
--- /dev/null
+++ b/i18npool/Executable_genindex_data.mk
@@ -0,0 +1,25 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,genindex_data))
+
+$(eval $(call gb_Executable_use_libraries,genindex_data,\
+ sal \
+))
+
+$(eval $(call gb_Executable_use_externals,genindex_data,\
+ icui18n \
+ icuuc \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,genindex_data,\
+ i18npool/source/indexentry/genindex_data \
+))
+
+# vim: set noet sw=4 ts=4: