summaryrefslogtreecommitdiffstats
path: root/i18npool/Executable_saxparser.mk
diff options
context:
space:
mode:
Diffstat (limited to 'i18npool/Executable_saxparser.mk')
-rw-r--r--i18npool/Executable_saxparser.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/i18npool/Executable_saxparser.mk b/i18npool/Executable_saxparser.mk
new file mode 100644
index 000000000..085dea641
--- /dev/null
+++ b/i18npool/Executable_saxparser.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,saxparser))
+
+$(eval $(call gb_Executable_use_sdk_api,saxparser))
+
+$(eval $(call gb_Executable_use_libraries,saxparser,\
+ cppu \
+ cppuhelper \
+ sal \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,saxparser,\
+ i18npool/source/localedata/LocaleNode \
+ i18npool/source/localedata/filewriter \
+ i18npool/source/localedata/saxparser \
+))
+
+# vim: set noet sw=4 ts=4: