summaryrefslogtreecommitdiffstats
path: root/jvmfwk/Executable_javaldx.mk
diff options
context:
space:
mode:
Diffstat (limited to 'jvmfwk/Executable_javaldx.mk')
-rw-r--r--jvmfwk/Executable_javaldx.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/jvmfwk/Executable_javaldx.mk b/jvmfwk/Executable_javaldx.mk
new file mode 100644
index 000000000..ab5ae8abe
--- /dev/null
+++ b/jvmfwk/Executable_javaldx.mk
@@ -0,0 +1,21 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,javaldx))
+
+$(eval $(call gb_Executable_use_libraries,javaldx,\
+ jvmfwk \
+ sal \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,javaldx,\
+ jvmfwk/plugins/sunmajor/javaenvsetup/javaldx \
+))
+
+# vim:set noet sw=4 ts=4: