summaryrefslogtreecommitdiffstats
path: root/onlineupdate/qa/replace_request
diff options
context:
space:
mode:
Diffstat (limited to 'onlineupdate/qa/replace_request')
-rw-r--r--onlineupdate/qa/replace_request/Makefile17
-rw-r--r--onlineupdate/qa/replace_request/README3
-rw-r--r--onlineupdate/qa/replace_request/updater.zipbin0 -> 1519 bytes
3 files changed, 20 insertions, 0 deletions
diff --git a/onlineupdate/qa/replace_request/Makefile b/onlineupdate/qa/replace_request/Makefile
new file mode 100644
index 000000000..476e93213
--- /dev/null
+++ b/onlineupdate/qa/replace_request/Makefile
@@ -0,0 +1,17 @@
+gb_Side := host
+include ../../../config_host.mk
+
+UPDATER_DIR := $(WORKDIR)/updater/replace_request
+
+unpack:
+ @echo "Unpacking the updater test project"
+ @rm -r $(UPDATER_DIR) || true
+ @mkdir -p $(WORKDIR)/updater
+ @unzip updater.zip -d $(WORKDIR)/updater > /dev/null
+
+call: unpack
+ @echo "Update the test project"
+ @$(INSTDIR)/program/updater $(UPDATER_DIR)/user/patch $(UPDATER_DIR) $(UPDATER_DIR)/user/update /replace
+
+call-gdb: unpack
+ gdb --args $(INSTDIR)/program/updater $(UPDATER_DIR)/user/patch $(UPDATER_DIR) $(UPDATER_DIR)/user/update /replace
diff --git a/onlineupdate/qa/replace_request/README b/onlineupdate/qa/replace_request/README
new file mode 100644
index 000000000..f50c692fd
--- /dev/null
+++ b/onlineupdate/qa/replace_request/README
@@ -0,0 +1,3 @@
+Tests the replacement request done by the automatic updater
+
+After calling 'make call' the content in workdir/updater/program/datei.txt should say "new".
diff --git a/onlineupdate/qa/replace_request/updater.zip b/onlineupdate/qa/replace_request/updater.zip
new file mode 100644
index 000000000..dc5e26b0f
--- /dev/null
+++ b/onlineupdate/qa/replace_request/updater.zip
Binary files differ