summaryrefslogtreecommitdiffstats
path: root/sal/CppunitTest_sal_comtools.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--sal/CppunitTest_sal_comtools.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/sal/CppunitTest_sal_comtools.mk b/sal/CppunitTest_sal_comtools.mk
new file mode 100644
index 000000000..1f9c24a0c
--- /dev/null
+++ b/sal/CppunitTest_sal_comtools.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,sal_comtools))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sal_comtools,\
+ sal/qa/systools/test_comtools \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,sal_comtools,\
+ sal \
+))
+
+$(eval $(call gb_CppunitTest_use_system_win32_libs,sal_comtools,\
+ ole32 \
+))
+
+# vim: set noet sw=4 ts=4: