summaryrefslogtreecommitdiffstats
path: root/scripting/Package_ScriptsPython.mk
diff options
context:
space:
mode:
Diffstat (limited to 'scripting/Package_ScriptsPython.mk')
-rw-r--r--scripting/Package_ScriptsPython.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/scripting/Package_ScriptsPython.mk b/scripting/Package_ScriptsPython.mk
new file mode 100644
index 000000000..9d401d383
--- /dev/null
+++ b/scripting/Package_ScriptsPython.mk
@@ -0,0 +1,21 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Package_Package,scripting_ScriptsPython,$(SRCDIR)/scripting/examples))
+
+$(eval $(call gb_Package_add_files_with_dir,scripting_ScriptsPython,$(LIBO_SHARE_FOLDER)/Scripts,\
+ python/Capitalise.py \
+ python/HelloWorld.py \
+ python/InsertText.py \
+ python/NamedRanges.py \
+ python/SetCellColor.py \
+ python/TableSample.py \
+))
+
+# vim: set noet sw=4 ts=4: