summaryrefslogtreecommitdiffstats
path: root/slideshow/CppunitTest_slideshow_engine.mk
diff options
context:
space:
mode:
Diffstat (limited to 'slideshow/CppunitTest_slideshow_engine.mk')
-rw-r--r--slideshow/CppunitTest_slideshow_engine.mk50
1 files changed, 50 insertions, 0 deletions
diff --git a/slideshow/CppunitTest_slideshow_engine.mk b/slideshow/CppunitTest_slideshow_engine.mk
new file mode 100644
index 000000000..a88531df4
--- /dev/null
+++ b/slideshow/CppunitTest_slideshow_engine.mk
@@ -0,0 +1,50 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,slideshow_engine))
+
+$(eval $(call gb_CppunitTest_use_externals,slideshow_engine,\
+ boost_headers \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,slideshow_engine, \
+ slideshow/qa/engine/engine \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,slideshow_engine, \
+ comphelper \
+ cppu \
+ slideshow \
+ sal \
+ test \
+ unotest \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,slideshow_engine))
+
+$(eval $(call gb_CppunitTest_set_include,slideshow_engine,\
+ -I$(SRCDIR)/slideshow/source/inc \
+ -I$(SRCDIR)/slideshow/source/engine/animationnodes \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,slideshow_engine))
+$(eval $(call gb_CppunitTest_use_vcl,slideshow_engine))
+
+$(eval $(call gb_CppunitTest_use_rdb,slideshow_engine,services))
+
+$(eval $(call gb_CppunitTest_use_custom_headers,slideshow_engine,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,slideshow_engine))
+
+# vim: set noet sw=4 ts=4: