summaryrefslogtreecommitdiffstats
path: root/solenv/gbuild/extensions/post_Counters.mk
diff options
context:
space:
mode:
Diffstat (limited to 'solenv/gbuild/extensions/post_Counters.mk')
-rw-r--r--solenv/gbuild/extensions/post_Counters.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/solenv/gbuild/extensions/post_Counters.mk b/solenv/gbuild/extensions/post_Counters.mk
new file mode 100644
index 000000000..8773844a5
--- /dev/null
+++ b/solenv/gbuild/extensions/post_Counters.mk
@@ -0,0 +1,22 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+ifneq ($(filter countoutdated,$(MAKECMDGOALS)),)
+
+gb_Output_announce=
+
+ifneq ($(strip $(filter-out countoutdated,$(MAKECMDGOALS))),)
+countoutdated: $(filter-out countoutdated,$(MAKECMDGOALS))
+else
+countoutdated: $(.DEFAULT_GOAL)
+endif
+
+endif
+
+# vim: set noet ts=4 sw=4: