summaryrefslogtreecommitdiffstats
path: root/solenv/gbuild/platform/linux.mk
diff options
context:
space:
mode:
Diffstat (limited to 'solenv/gbuild/platform/linux.mk')
-rw-r--r--solenv/gbuild/platform/linux.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/solenv/gbuild/platform/linux.mk b/solenv/gbuild/platform/linux.mk
new file mode 100644
index 000000000..8fc7d38e3
--- /dev/null
+++ b/solenv/gbuild/platform/linux.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+gb__LinkTarget_LDFLAGS_zdefs := -Wl,-z,defs
+ifeq ($(COM_IS_CLANG),TRUE)
+ifneq ($(filter -fsanitize=%,$(CC) $(LDFLAGS)),)
+gb__LinkTarget_LDFLAGS_zdefs :=
+endif
+endif
+gb_LinkTarget_LDFLAGS += $(gb__LinkTarget_LDFLAGS_zdefs)
+
+include $(GBUILDDIR)/platform/unxgcc.mk
+
+ifneq ($(ATOMIC_LIB),)
+gb_STDLIBS_CXX := $(ATOMIC_LIB)
+endif
+
+# vim: set noet sw=4 ts=4: