summaryrefslogtreecommitdiffstats
path: root/solenv/qa/python/selftest/Library_gbuildselftest.mk
diff options
context:
space:
mode:
Diffstat (limited to 'solenv/qa/python/selftest/Library_gbuildselftest.mk')
-rw-r--r--solenv/qa/python/selftest/Library_gbuildselftest.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/solenv/qa/python/selftest/Library_gbuildselftest.mk b/solenv/qa/python/selftest/Library_gbuildselftest.mk
new file mode 100644
index 000000000..bed015c09
--- /dev/null
+++ b/solenv/qa/python/selftest/Library_gbuildselftest.mk
@@ -0,0 +1,37 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,gbuildselftest))
+
+$(eval $(call gb_Library_set_include,gbuildselftest,\
+ -Igbuildtojsontestinclude\
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_add_defs,gbuildselftest,\
+ -DGBUILDSELFTESTDEF \
+))
+
+$(eval $(call gb_Library_add_cxxflags,gbuildselftest,\
+ -DGBUILDSELFTESTCXXFLAG \
+))
+
+$(eval $(call gb_Library_add_cflags,gbuildselftest,\
+ -DGBUILDSELFTESTCFLAG \
+))
+
+$(eval $(call gb_Library_use_libraries,gbuildselftest,\
+ gbuildselftestdep \
+))
+
+$(eval $(call gb_Library_add_exception_objects,gbuildselftest,\
+ solenv/qa/python/selftest/selftestobject \
+))
+
+# vim: set noet sw=4 ts=4: