summaryrefslogtreecommitdiffstats
path: root/stoc/Library_introspection.mk
diff options
context:
space:
mode:
Diffstat (limited to 'stoc/Library_introspection.mk')
-rw-r--r--stoc/Library_introspection.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/stoc/Library_introspection.mk b/stoc/Library_introspection.mk
new file mode 100644
index 000000000..58ce9e404
--- /dev/null
+++ b/stoc/Library_introspection.mk
@@ -0,0 +1,29 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,introspection))
+
+$(eval $(call gb_Library_use_external,introspection,boost_headers))
+
+$(eval $(call gb_Library_use_udk_api,introspection))
+
+$(eval $(call gb_Library_use_libraries,introspection,\
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_Library_set_componentfile,introspection,stoc/source/inspect/introspection,ure/services))
+
+$(eval $(call gb_Library_add_exception_objects,introspection,\
+ stoc/source/inspect/introspection \
+))
+
+# vim:set noet sw=4 ts=4: