summaryrefslogtreecommitdiffstats
path: root/stoc/unosdk.mk
diff options
context:
space:
mode:
Diffstat (limited to 'stoc/unosdk.mk')
-rw-r--r--stoc/unosdk.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/stoc/unosdk.mk b/stoc/unosdk.mk
new file mode 100644
index 000000000..b28206536
--- /dev/null
+++ b/stoc/unosdk.mk
@@ -0,0 +1,25 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PPATH=inc
+
+FILES= \
+ $(PPATH)\stoc\component.hxx
+
+unosdk: $(FILES)
+ docpp -H -m -f -u -d ..\..\doc\stoc $(FILES)